Exim/mail problem med php

Forum för OpenVZ-relaterad diskussion
binx
Inlägg: 4
Blev medlem: 11 jan 2009, 22:34

Exim/mail problem med php

Inläggav binx » 11 sep 2009, 14:04

Hej.

Jag har ett par problem på min vps, en Guld-VPS med burst avstängt och Debian 5.0.

Jag har Exim 4 installerat och konfigurerat. Skicka mail med mailkommandot från shell
funkar som det ska och även att skicka med /usr/sbin/sendmail.

Däremot funkar det inte att skicka med PHP. mail()-funktionen returnerar false, vilket skall
innebära kommunikationsproblem med sendmail vad jag har förstått. Sedan går ett mail ut till
root som förstås vidarebefordras till min mail.

Där får jag felmeddelandet (ändrade domän till example.com):

----

A system failure was encountered while processing a message that you sent,
so it has not been possible to deliver it. The error was:

Input read error (Input/output error) while receiving message from root

------ This is a copy of your message, including all the headers. ------

Message-Id: <A1Fg7W3-20312Q-TR@example.com>
From: root <root@example.com>
Date: Fri, 11 Sep 2009 13:38:01 +0200

----

I exim-loggen får jag detta felmeddelande:

----

2009-09-11 13:38:01 1Mm4S1-00012P-TR Message abandoned: Input read error (Input/output error) while receiving message from root
2009-09-11 13:38:01 1Mm4S1-00012Q-Tn <= <> R=1Mm4S1-00012P-TR U=Debian-exim P=local S=776
2009-09-11 13:38:02 1Mm4S1-00012Q-Tn => somename@example.com <root@example.com> R=dnslookup T=remote_smtp H=aspmx.l.google.com [209.85.219.53]
2009-09-11 13:38:02 1Mm4S1-00012Q-Tn Completed

----

För övrigt verkar inte netstat -p funka som det ska. Den visar INGA pids eller programnamn i den kolumnen,
såhär ser det ut:

Proto RefCnt Flags Type State I-Node PID/Program name Path
unix 8 [ ] DGRAM 4242061463 - /dev/log
unix 3 [ ] STREAM CONNECTED 4242986509 -
unix 3 [ ] STREAM CONNECTED 4242986508 -
unix 3 [ ] STREAM CONNECTED 4242986506 -
unix 3 [ ] STREAM CONNECTED 4242986505 -
unix 3 [ ] STREAM CONNECTED 4242986503 -
unix 3 [ ] STREAM CONNECTED 4242986502 -
unix 3 [ ] STREAM CONNECTED 4242986500 -
unix 3 [ ] STREAM CONNECTED 4242986499 -
unix 3 [ ] STREAM CONNECTED 4242986497 -
unix 3 [ ] STREAM CONNECTED 4242986496 -
unix 3 [ ] STREAM CONNECTED 4242986494 -
unix 3 [ ] STREAM CONNECTED 4242986493 -
unix 3 [ ] STREAM CONNECTED 4242986491 -
unix 3 [ ] STREAM CONNECTED 4242986490 -
unix 3 [ ] STREAM CONNECTED 4242986488 -
unix 3 [ ] STREAM CONNECTED 4242986487 -
unix 2 [ ] DGRAM 4242882598 -
unix 2 [ ] DGRAM 4242333151 -
unix 2 [ ] DGRAM 4242063138 -
unix 2 [ ] DGRAM 4242063127 -
unix 3 [ ] STREAM CONNECTED 4242062183 -
unix 3 [ ] STREAM CONNECTED 4242062182 -
unix 3 [ ] STREAM CONNECTED 4242062179 -
unix 3 [ ] STREAM CONNECTED 4242062178 -
unix 2 [ ] DGRAM 4242061760 -
unix 2 [ ] DGRAM 4242061494 -

(bara ett "-" där det bör stå pid/programnamn).

Har någon varit med om detta förut?

user_beancounters rapporterar inget failcnt och free rapporterar över hälften av minnet som ledigt (total 1024 MB).

Har förresten också testat att installera postfix och sendmail istället för exim4 men då får jag liknande felmeddelande,
t. ex från sendmail "sendmail[3638]: n8A8uHaC003638: collect: premature EOM: Input/output error".

/John

binx
Inlägg: 4
Blev medlem: 11 jan 2009, 22:34

Re: Exim/mail problem med php

Inläggav binx » 12 sep 2009, 11:36

Nu är problemen lösta. Eftersom det var så konstiga problem och det inte gick att hitta något liknande via google bad jag om att få min OpenVZ-nod flyttad till en annan hårdvarunod för att på det viset utesluta problem på hårdvarunoden. Efter flytten försvann alla mina problem (vissa andra konstigheter som jag aldrig listade i min postning försvann också). Alltså måste något ha varit fel på hårdvarunoden min vps fanns på. Vad felet var kan jag inte svara på, men kanske kan någon från Glesys... jag är bara glad att allt funkar som det ska nu.

F.ö. var det efter att jag tagit en snapshot på min container och gjort en helt ren Debian 5 installation och i den testat netstat -p, som då också gav konstig output, som jag bad om att få noden flyttad. För all del kan man göra felaktig config men om noden redan som helt ren installation gör konstiga saker är felet knappast ens eget.

/J


Återgå till "OpenVZ"

Vilka är online

Användare som besöker denna kategori: 1 och 0 gäst